SUSE LINUX Enterprise & openSUSE Community
มิถุนายน 25, 2019, 03:32:51 PM *
ยินดีต้อนรับคุณ, บุคคลทั่วไป กรุณา เข้าสู่ระบบ หรือ ลงทะเบียน
ส่งอีเมล์ยืนยันการใช้งาน?

เข้าสู่ระบบด้วยชื่อผู้ใช้ รหัสผ่าน และระยะเวลาในเซสชั่น
ข่าว:
 
   หน้าแรก   ช่วยเหลือ ค้นหา เข้าสู่ระบบ สมัครสมาชิก  

[Why we need your support] SUSE and openSUSE are trademarks of Attachmate Group, Inc. - WE ARE NOT IN ANY WAY ASSOCIATED WITH SUSE AND ATTACHMATE GROUP. SUSEThailand.com is a SUSE Linux user and community found in Thailand but not limited to other country suse linux user to join in. Currently active contents (How to's, Scripts, Tips, Tricks, Tutorials, Linux Command Line, and Troubleshooting) this suse linux how to's and expert support are SUSE Linux.
หน้า: [1]   ลงล่าง
  พิมพ์  
ผู้เขียน
หัวข้อ: How to compile Inkscape Latest stable version: 0.48 on openSUSE 11.3  (อ่าน 5705 ครั้ง)
0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้
Sontaya
Administrator
Expert : ผู้เชี่ยวชาญ
*****

Karma: +1/-0
ออฟไลน์ ออฟไลน์

กระทู้: 1931


Administrator


เว็บไซต์
« เมื่อ: พฤศจิกายน 03, 2010, 09:26:41 AM »


First, Check packages is required:
=====================
The most typical libraries you may need to install are:
e.g (i=installed)

$ zypper se libsigc++2

   * libsigc++2
   * glibmm
   * gtkmm2
   * boehm-gc


Solution:
======

1. Compile Garbage collector for C and C++ (gc)
$ cd /opt/
$ wget http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc.tar.gz
$ tar zxvf gc.tar.gz
$ cd gc6.8/
$ ./configure --enable-cplus-plus
$ make && make install


2. Compile Inkscape (Around 1 hour):
- Download source
$ cd /opt/
$ wget http://downloads.sourceforge.net/inkscape/inkscape-0.48.0.tar.gz
$ tar zxvf inkscape-0.48.0.tar.gz
$ cd inkscape-0.48.0


- Configure it with the command:
$ ./configure
โค๊ด:
...
config.status: executing depfiles commands
config.status: executing default-1 commands
config.status: executing po/stamp-it commands

Configuration:

        Source code location:     .
        Destination path prefix:  /usr/local
        Compiler:                 g++
        CPPFLAGS:                 -Werror=format-security -Wall -Wformat -Wformat-security -W -D_FORTIFY_SOURCE=2
        CXXFLAGS:                 -Wpointer-arith -Wcast-align -Wsign-compare -Woverloaded-virtual -Wswitch -Wno-unused-parameter -g -O2 -fopenmp
        CFLAGS:                   -Wno-pointer-sign -g -O2
        LDFLAGS:                  -Wl,-z,relro

        Use Xft font database:    yes
        Use gnome-vfs:            no
        Use openoffice files:     yes
        Use relocation support:   no
        Internal Python:          skipped
        Internal Perl:            skipped
        Enable LittleCms:         yes
        Enable Poppler-Cairo:     yes
        ImageMagick Magick++:     no
        Libwpg:                   no
...

- Build & Install it with:
$ make && make install
...
test -z "/usr/local/share/applications" || /bin/mkdir -p "/usr/local/share/applications"
/usr/bin/install -c -m 644 inkscape.desktop '/usr/local/share/applications'
/bin/sh ./mkinstalldirs /usr/local/share/man/fr/man1
mkdir -p -- /usr/local/share/man/fr/man1
/usr/bin/install -c -m 644 `if [ -f inkscape.fr.1 ]; then :; else echo ./;fi`inkscape.fr.1 /usr/local/share/man/fr/man1/inkscape.1
test -z "/usr/local/share/man/man1" || /bin/mkdir -p "/usr/local/share/man/man1"
/usr/bin/install -c -m 644 inkscape.1 inkview.1 '/usr/local/share/man/man1'
make[2]: Leaving directory `/opt/inkscape-0.48.0'
make[1]: Leaving directory `/opt/inkscape-0.48.0'
...

- Reboot
$ shutdown -r now


Open Inkscape 0.48
=============

Computer > More Applications > Inkscape


Troubleshooting for openSUSE 11.3 (64bit):
============================

1) Error: Checking for INKSCAPE... configure: error: Package requirements (gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0  libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12    gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

$ ./configure
Checking for INKSCAPE... configure: error: Package requirements (gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0  libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12    gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

No package 'gdkmm-2.4' found
No package 'glibmm-2.4' found
No package 'giomm-2.4' found
No package 'gtkmm-2.4' found
No package 'sigc++-2.0' found
No package 'gsl' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables INKSCAPE_CFLAGS
and INKSCAPE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Solution: make sure you have installed
gtkmm2-devel, gsl-devel, boost-devel, liblcms-devel

2) Error: configure: error: libpopt is required
$ ./configure
configure: error: libpopt is required

Solution: make sure you have installed popt-devel (Development files for the popt library)
« แก้ไขครั้งสุดท้าย: พฤศจิกายน 04, 2010, 04:06:47 PM โดย Sontaya » แจ้งลบกระทู้นี้หรือติดต่อผู้ดูแล   บันทึกการเข้า

ageLOC Technology
หน้า: [1]   ขึ้นบน
  พิมพ์  
 
กระโดดไป:  

(@)2007 SUSE Linux user community found in Thailand. This site is not an official openSUSE and SUSE website, and is not in any way affiliated with or endorsed by SUSE Linux GmbH or Novell. openSUSE and SUSE are trademarks of Novell, Inc. in the United States and other countries.
Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!
หน้านี้ถูกสร้างขึ้นภายในเวลา 0.062 วินาที กับ 20 คำสั่ง (Pretty URLs adds 0.011s, 2q)